Viewing 1 post (of 1 total)
  • Author
    Posts
  • #10462
    Russell Medina
    Keymaster

    Hola a todos, si en alguna ocasion se les ha presetnado el caso de que al crear un vehiculo inicie con un contador de odometro leido por el Ecu por default, a continuacion te muestro cual puede ser el motivo y como solucionar esto.

    Si un vehiculo esta siendo usado para pruebas o ha presentado muchas asociaciones y en algun momento ese vehiculo tuvo un ecu monitor en alguno de sus dispositivos asociados o se le asigno el contador de odometro leido por el ecu monitor, los siguientes dispositivos que se asocien iniciaran con el mismo contador ya que los contadores de un dispositivo se sincroniza con el siguiente asociado.

    Estas api te pueden ayudar a diagnosticar esto

    -Con la api de changelogs podemos saber si nuestro vehiculo a sido asociado a diferentes dispositivos
    (Sustituir urldepegasus por la url de tu sitio y VID por el id de tu vehiculo)

    https://urldepegasus/api/changelogs?from=2020-06-01&path=/api/vehicles/VID&full=1

    Obtendremos una respuesta como esta en ser el caso

    2

    -Con la api de devices podemos saber si antes nuestro dispositivo estuvo asociado a otro vehiculo.

    (Sustituir urldepegasus por la url de tu sitio e Imei por el imei de tu dispositivo)

    https://urldepegasus/api/devices/Imei

    Obtendremos una respuesta como esta en ser el caso

    3

     

    Para solucionar o evitar este tema, al crear un vehiculo nuevo, siempre debemos asegurarnos de establecer los contadores que necesitaremos y dejar en 0 los que no.

Viewing 1 post (of 1 total)
  • You must be logged in to reply to this topic.